import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+((\\-?| ?)\\w+)? [a-bA-B] (\\d{9}|((\\d{3} ){2}\\d{3}))$";
final String string = "CLERMONTFERRAND B 321 654 897\n"
+ "Paris A 321 546 987\n"
+ "Test Rien B 645213564\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}