const regex = /^\w+((\-?| ?)\w+)? [a-bA-B] (\d{9}|((\d{3} ){2}\d{3}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+((\\-?| ?)\\w+)? [a-bA-B] (\\d{9}|((\\d{3} ){2}\\d{3}))$', 'gm')
const str = `CLERMONTFERRAND B 321 654 897
Paris A 321 546 987
Test Rien B 645213564
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}