$re = '/^\w+((\-?| ?)\w+)? [a-bA-B] (\d{9}|((\d{3} ){2}\d{3}))$/m';
$str = 'CLERMONTFERRAND B 321 654 897
Paris A 321 546 987
Test Rien B 645213564
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);