using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a(?:\[\d])?\.b(?:\[\d])?\.c(?:\[\d])?\.d(?:\[\d])?\.e(?:\[\d])?";
string input = @"a.b.c.d.e
a[0].b.c.d[0].e
a[0].b.c.d[1].e
a[1].b.c.d[0].e
a[1].b.c.d[1].e";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}