import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a(?:\\[\\d])?\\.b(?:\\[\\d])?\\.c(?:\\[\\d])?\\.d(?:\\[\\d])?\\.e(?:\\[\\d])?";
final String string = "a.b.c.d.e\n"
+ "a[0].b.c.d[0].e\n"
+ "a[0].b.c.d[1].e\n"
+ "a[1].b.c.d[0].e\n"
+ "a[1].b.c.d[1].e";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}