const regex = /a(?:\[\d])?\.b(?:\[\d])?\.c(?:\[\d])?\.d(?:\[\d])?\.e(?:\[\d])?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a(?:\\[\\d])?\\.b(?:\\[\\d])?\\.c(?:\\[\\d])?\\.d(?:\\[\\d])?\\.e(?:\\[\\d])?', 'gm')
const str = `a.b.c.d.e
a[0].b.c.d[0].e
a[0].b.c.d[1].e
a[1].b.c.d[0].e
a[1].b.c.d[1].e`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}