$re = '/a(?:\[\d])?\.b(?:\[\d])?\.c(?:\[\d])?\.d(?:\[\d])?\.e(?:\[\d])?/m';
$str = 'a.b.c.d.e
a[0].b.c.d[0].e
a[0].b.c.d[1].e
a[1].b.c.d[0].e
a[1].b.c.d[1].e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);