# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\"(?!key\")(.+?)\"/$1/g;t' <<< "\"person\",\"hobby\",\"key\""