import Foundation
let pattern = #"\"(?!key\")(.+?)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""person","hobby","key""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)