const regex = new RegExp('\\"(?!key\\")(.+?)\\"', 'g')
const str = `"person","hobby","key"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);