#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\"(?!key\")(.+?)\""
Local $sString = ""person","hobby","key""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)