using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[link ((?:\w+=""\w+"" ?)+)\]";
string input = @"[link test=""pao"" last=""joao""] fqwfqwf [linfk test=""pao"" last=""joao""] asfasf [llink test=""pao"" last=""joao""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}