const regex = /\[link ((?:\w+="\w+" ?)+)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[link ((?:\\w+="\\w+" ?)+)\\]', 'g')
const str = `[link test="pao" last="joao"] fqwfqwf [linfk test="pao" last="joao"] asfasf [llink test="pao" last="joao"]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}