package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[link ((?:\w+="\w+" ?)+)\]`)
var str = `[link test="pao" last="joao"] fqwfqwf [linfk test="pao" last="joao"] asfasf [llink test="pao" last="joao"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}