re = /\[link ((?:\w+="\w+" ?)+)\]/
str = '[link test="pao" last="joao"] fqwfqwf [linfk test="pao" last="joao"] asfasf [llink test="pao" last="joao"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end