#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div[^>]*>((?:(?R)|(?:(?!<\/?div)[\s\S]))*)<\/div>"
Local $sString = "<div class="1">abc" & @CRLF & _
"<!-- " & @CRLF & _
"comentario </div>" & @CRLF & _
"-->" & @CRLF & _
"xyz" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div class="1" >" & @CRLF & _
"abc" & @CRLF & _
"<p>div2</p>" & @CRLF & _
"xyz" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")