re = /<div[^>]*>((?:(?R)|(?:(?!<\/?div)[\s\S]))*)<\/div>/m
str = '<div class="1">abc
<!--
comentario </div>
-->
xyz
</div>
<div class="1" >
abc
<p>div2</p>
xyz
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end