using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div[^>]*>((?:(?R)|(?:(?!<\/?div)[\s\S]))*)<\/div>";
string input = @"<div class=""1"">abc
<!--
comentario </div>
-->
xyz
</div>
<div class=""1"" >
abc
<p>div2</p>
xyz
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}