import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div[^>]*>((?:(?R)|(?:(?!<\\/?div)[\\s\\S]))*)<\\/div>";
final String string = "<div class=\"1\">abc\n"
+ "<!-- \n"
+ "comentario </div>\n"
+ "-->\n"
+ "xyz\n"
+ "</div>\n\n"
+ "<div class=\"1\" >\n"
+ "abc\n"
+ "<p>div2</p>\n"
+ "xyz\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}