#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*(?<!\d)(\d+)$"
Local $sString = "2^64" & @CRLF & _
"asdgaf1_hsg534" & @CRLF & _
"asdfh23_hsjd12" & @CRLF & _
"dgshg_jhfsd86" & @CRLF & _
"test" & @CRLF & _
"1" & @CRLF & _
"testing 1234 testing 1 test4" & @CRLF & _
"testing 1234 testing 123" & @CRLF & _
"test 123 test" & @CRLF & _
"this is a test"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)