import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(?<!\\d)(\\d+)$";
final String string = "2^64\n"
+ "asdgaf1_hsg534\n"
+ "asdfh23_hsjd12\n"
+ "dgshg_jhfsd86\n"
+ "test\n"
+ "1\n"
+ "testing 1234 testing 1 test4\n"
+ "testing 1234 testing 123\n"
+ "test 123 test\n"
+ "this is a test";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}