re = /^.*(?<!\d)(\d+)$/m
str = '2^64
asdgaf1_hsg534
asdfh23_hsjd12
dgshg_jhfsd86
test
1
testing 1234 testing 1 test4
testing 1234 testing 123
test 123 test
this is a test'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result