import re
regex = re.compile(r"^.*(?<!\d)(\d+)$", flags=re.MULTILINE)
test_str = ("2^64\n"
"asdgaf1_hsg534\n"
"asdfh23_hsjd12\n"
"dgshg_jhfsd86\n"
"test\n"
"1\n"
"testing 1234 testing 1 test4\n"
"testing 1234 testing 123\n"
"test 123 test\n"
"this is a test")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)