#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^.:.+?:.+?:(.*debit.*)$"
Local $sString = "C:\temp\TRANSFile1.txt:1001:DTRANS 1.111111111 12345667889 debit product1" & @CRLF & _
"C:\temp\TRANSFile1.txt:20002:DTRANS 2.222222222 23143453456 credit product2" & @CRLF & _
"C:\temp\TRANSFile1.txt:300:DTRANS 3.333333333 23443655678 debit product3" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")