import Foundation
let pattern = #"^.:.+?:.+?:(.*debit.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
C:\temp\TRANSFile1.txt:1001:DTRANS 1.111111111 12345667889 debit product1
C:\temp\TRANSFile1.txt:20002:DTRANS 2.222222222 23143453456 credit product2
C:\temp\TRANSFile1.txt:300:DTRANS 3.333333333 23443655678 debit product3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)