# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.:.+?:.+?:(.*debit.*)$"
test_str = ("C:\\temp\\TRANSFile1.txt:1001:DTRANS 1.111111111 12345667889 debit product1\n"
"C:\\temp\\TRANSFile1.txt:20002:DTRANS 2.222222222 23143453456 credit product2\n"
"C:\\temp\\TRANSFile1.txt:300:DTRANS 3.333333333 23443655678 debit product3\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.