$re = '/^.:.+?:.+?:(.*debit.*)$/mi';
$str = 'C:\\temp\\TRANSFile1.txt:1001:DTRANS 1.111111111 12345667889 debit product1
C:\\temp\\TRANSFile1.txt:20002:DTRANS 2.222222222 23143453456 credit product2
C:\\temp\\TRANSFile1.txt:300:DTRANS 3.333333333 23443655678 debit product3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);