use strict;
my $str = '<li class="ulchildlink" data-hd-product="SSEPEK_11.0.0" data-hd-operatingsystem="zOS"><span class="ulchildlinktext"><a href="../../src/tpc/n007.html?view=kc">-007</a></span><br>
STATEMENT CONTAINS THE ILLEGAL CHARACTER <var class="keyword varname ibm-item-note-alternate">invalid-character</var></li>';
my $regex = qr/<([^<>\/\s]+)[^<>]*>/mp;
my $subst = '<\\1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";