#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\w+(?:\s+\w+)*?(?:\s*<\w+>)?\s+(\w+)(?=\s*[=;])"
Local $sString = "import java.io.File;" & @CRLF & _
"import java.io.IOException;" & @CRLF & _
"import java.util.ArrayList;" & @CRLF & _
"import java.util.List;" & @CRLF & _
"" & @CRLF & _
"private final String COMMENTS = "test";" & @CRLF & _
"private final String VARIABLE_NAME_REGEX="(\w*)<?>?\s*=(?=(?:[^"]|"[^"]*["])*$)";" & @CRLF & _
"String test="test";" & @CRLF & _
"String test222;" & @CRLF & _
"String includeThisAlso ;" & @CRLF & _
"List <String> arr;" & @CRLF & _
"List <String> list=null;" & @CRLF & _
"private final String COMMENTS = "test";" & @CRLF & _
"" & @CRLF & _
"private List<String> test;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")