import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\w+(?:\\s+\\w+)*?(?:\\s*<\\w+>)?\\s+(\\w+)(?=\\s*[=;])";
final String string = "import java.io.File;\n"
+ "import java.io.IOException;\n"
+ "import java.util.ArrayList;\n"
+ "import java.util.List;\n\n"
+ "private final String COMMENTS = \"test\";\n"
+ "private final String VARIABLE_NAME_REGEX=\"(\\w*)<?>?\\s*=(?=(?:[^\"]|\"[^\"]*[\"])*$)\";\n"
+ "String test=\"test\";\n"
+ "String test222;\n"
+ "String includeThisAlso ;\n"
+ "List <String> arr;\n"
+ "List <String> list=null;\n"
+ "private final String COMMENTS = \"test\";\n\n"
+ "private List<String> test;\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}