using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\w+(?:\s+\w+)*?(?:\s*<\w+>)?\s+(\w+)(?=\s*[=;])";
string input = @"import java.io.File;
import java.io.IOException;
import java.util.ArrayList;
import java.util.List;
private final String COMMENTS = ""test"";
private final String VARIABLE_NAME_REGEX=""(\w*)<?>?\s*=(?=(?:[^""]|""[^""]*[""])*$)"";
String test=""test"";
String test222;
String includeThisAlso ;
List <String> arr;
List <String> list=null;
private final String COMMENTS = ""test"";
private List<String> test;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}