#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\.][A-Za-z0-9-_]+\.(?:gif|jpeg|jpg|pdf|png|tiff|tif|psd|eps|bmp)$"
Local $sString = "image.jpg" & @CRLF & _
"another-image.png" & @CRLF & _
"underscore_image.psd" & @CRLF & _
"image.txt" & @CRLF & _
".hidden.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")