import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\.][A-Za-z0-9-_]+\\.(?:gif|jpeg|jpg|pdf|png|tiff|tif|psd|eps|bmp)$";
final String string = "image.jpg\n"
+ "another-image.png\n"
+ "underscore_image.psd\n"
+ "image.txt\n"
+ ".hidden.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}