$re = '/^[^\.][A-Za-z0-9-_]+\.(?:gif|jpeg|jpg|pdf|png|tiff|tif|psd|eps|bmp)$/m';
$str = 'image.jpg
another-image.png
underscore_image.psd
image.txt
.hidden.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);