using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\.][A-Za-z0-9-_]+\.(?:gif|jpeg|jpg|pdf|png|tiff|tif|psd|eps|bmp)$";
string input = @"image.jpg
another-image.png
underscore_image.psd
image.txt
.hidden.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}