#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)'depends':\s*(?:\[\s*)(.*?)(?:\s*\])"
Local $sString = "'category': 'Sales/Subscription'," & @CRLF & _
"'depends': [" & @CRLF & _
" 'sale_subscription'," & @CRLF & _
" 'sale_timesheet'," & @CRLF & _
"]," & @CRLF & _
"'auto_install': True,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")