package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)'depends':\s*(?:\[\s*)(.*?)(?:\s*\])`)
var str = `'category': 'Sales/Subscription',
'depends': [
'sale_subscription',
'sale_timesheet',
],
'auto_install': True,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}