using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'depends':\s*(?:\[\s*)(.*?)(?:\s*\])";
string input = @"'category': 'Sales/Subscription',
'depends': [
'sale_subscription',
'sale_timesheet',
],
'auto_install': True,";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}