$re = '/\'depends\':\s*(?:\[\s*)(.*?)(?:\s*\])/ms';
$str = '\'category\': \'Sales/Subscription\',
\'depends\': [
\'sale_subscription\',
\'sale_timesheet\',
],
\'auto_install\': True,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);