#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\R["']\s*(OI|OX|OPSIMEX)\s*["'](\S*)["']"
Local $sString = ""OX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"" & @CRLF & _
""OI 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"" & @CRLF & _
""OPSIMEX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"" & @CRLF & _
""OX PUBLIC.USER.REXX(EXTREXX)"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")