import re
regex = re.compile(r"\R[\"']\s*(OI|OX|OPSIMEX)\s*[\"'](\S*)[\"']", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\"OX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"\n"
"\"OI 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"\n"
"\"OPSIMEX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'\"\n"
"\"OX PUBLIC.USER.REXX(EXTREXX)\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")