import Foundation
let pattern = #"\R["']\s*(OI|OX|OPSIMEX)\s*["'](\S*)["']"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
"OX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OI 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OPSIMEX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OX PUBLIC.USER.REXX(EXTREXX)"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)