const regex = /\R["']\s*(OI|OX|OPSIMEX)\s*["'](\S*)["']/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\R["\']\\s*(OI|OX|OPSIMEX)\\s*["\'](\\S*)["\']', 'gmi')
const str = `"OX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OI 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OPSIMEX 'EDDMA01.PUBLIC.USER.REXX(EXTREXX)'"
"OX PUBLIC.USER.REXX(EXTREXX)"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}