using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?:docstring|some_detailed_notes)\s+=\s+
(?(?="").+|(\(([^()]|(?R))*\));)";
string input = @"docstring = ""mystr"";
docstring = ""some \""subs"" + some_str + ""next"";
test = ""some other weirdo text"";
test12 = 123;
docstring = (
some_str + ""cde"" + some_str + ""efg"" + another_str + ""ghi""
);
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}