$re = '~^
(?:docstring|some_detailed_notes)\s+=\s+
(?(?=").+|(\(([^()]|(?R))*\));)~mx';
$str = 'docstring = "mystr";
docstring = "some \\"subs" + some_str + "next";
test = "some other weirdo text";
test12 = 123;
docstring = (
some_str + "cde" + some_str + "efg" + another_str + "ghi"
);
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);