// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)^
(?:docstring|some_detailed_notes)\s+=\s+
(?(?=").+|(\(([^()]|(?R))*\));)"#).unwrap();
let string = "docstring = \"mystr\";
docstring = \"some \\\"subs\" + some_str + \"next\";
test = \"some other weirdo text\";
test12 = 123;
docstring = (
some_str + \"cde\" + some_str + \"efg\" + another_str + \"ghi\"
);
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}