use strict;
my $str = 'docstring = "mystr";
docstring = "some \\"subs" + some_str + "next";
test = "some other weirdo text";
test12 = 123;
docstring = (
some_str + "cde" + some_str + "efg" + another_str + "ghi"
);
';
my $regex = qr~^
(?:docstring|some_detailed_notes)\s+=\s+
(?(?=").+|(\(([^()]|(?R))*\));)~mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}