const regex = /'((?:[^'\\]|\\.)*asmx(?:[^'\\]|\\.)*)'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'((?:[^\'\\\\]|\\\\.)*asmx(?:[^\'\\\\]|\\\\.)*)\'', 'g')
const str = `CCKeyUpDomReady('test.asmx/asdasd', 'QMlPJZTOH09XOPCcbB2jcg==', '0OO6h+G2Tzhr5XWj1Upg0A==', '0OO6h+G2Tzhr5XWj1Upg0A==', '/qqwweq2.asmx/qqq')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}