re = /'((?:[^'\\]|\\.)*asmx(?:[^'\\]|\\.)*)'/
str = 'CCKeyUpDomReady(\'test.asmx/asdasd\', \'QMlPJZTOH09XOPCcbB2jcg==\', \'0OO6h+G2Tzhr5XWj1Upg0A==\', \'0OO6h+G2Tzhr5XWj1Upg0A==\', \'/qqwweq2.asmx/qqq\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end