$re = '/\'((?:[^\'\\\\]|\\\\.)*asmx(?:[^\'\\\\]|\\\\.)*)\'/';
$str = 'CCKeyUpDomReady(\'test.asmx/asdasd\', \'QMlPJZTOH09XOPCcbB2jcg==\', \'0OO6h+G2Tzhr5XWj1Upg0A==\', \'0OO6h+G2Tzhr5XWj1Upg0A==\', \'/qqwweq2.asmx/qqq\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);